您现在的位置 : 路由人 > 路由器设置 > 正文 IP地址冲突 路由人教你更换IP地址 / 如何防蹭网的终极解决办法 / 连接上192.168.1.1没有账号、密码输入框 /

金浪路由器命令行配置ADSL

通过管理页面进行设置ADSL上网相信大家都知道怎么做,但是在有些高端路由中,我们采用的是命令行方式进行配置,这就不是所有人都知道了,今天我们就以金浪路由用命令行来配置ADSL,这里我们要用到一个modem和一台...

通过管理页面进行设置ADSL上网相信大家都知道怎么做,但是在有些高端路由中,我们采用的是命令行方式进行配置,这就不是所有人都知道了,今天我们就以金浪路由用命令行来配置ADSL,这里我们要用到一个modem和一台路由器。


 

一、配置vpdn

vpdn enable 启用路由器的虚拟专用拨号网络vpnd

vpdn-group office 建立一个vpdn组

request-dialin 初始化一个vpnd tunnel,建立一个请求拨入的vpdn子组

protocol pppoe vpdn子组使用pppoe建立会话隧道

二、配置路由器连接adsl modem的接口

interface Ethernet1

no ip address

pppoe enable允许以太接口运行pppoe

pppoe-client dial-pool-number 1将以太接口的pppoe拨号客户端加入拨号池1

三、配置逻辑拨号接口

interface Dialer1

ip address negotiated从adsl服务商动态协商得到ip地址

ip nat outside为该接口启用NAT

encapsulation ppp为该接口封装ppp协议

dialer pool 1该接口使用1号拨号池进行拨号

dialer-group 1该命令对于pppoe是意义不大的

ppp authentication pap callin启用ppp pap验证

ppp pap sent-username xxxxxxx password 0 yyyyyyy使用已经申请的用户名和口令

四、配置内部网络接口

interface Ethernet0 内部网络接口

ip address 10.1.1.1 255.255.255.0

ip nat inside为该接口启用NAT

五、配置路由器为内部网络主机提供dhcp服务

ip dhcp excluded-address 10.1.1.1

ip dhcp pool ABC

import all 导入dns和wins server

network 10.1.1.0 255.255.255.0

default-router 10.1.1.1

六、配置NAT

access-list 1 permit 10.1.1.0 0.0.0.255

ip nat inside source list 1 interface Dialer1 overload

最后,我们只要配置一下缺省路由,那么整个设置就完成了,只要你能按以上主步骤进行设置,那么你就一定可以快速而准确的设置好路由器上网了。

延伸阅读:
  • 本月热点
  • 随机推荐
路由人提示:如需转载本站无线连接及路由器设置等技术文章请您注明出处,谢谢!
Copyright © www.LuYouRen.com, All Rights Reserved.
  苏ICP备12075116号