您现在的位置 : 路由人 > 路由器设置 > 正文 IP地址冲突 路由人教你更换IP地址 / 如何防蹭网的终极解决办法 / 连接上192.168.1.1没有账号、密码输入框 /

routeros设置双ADSL负载平衡脚本

今天,教大家通过routeros设置双ADSL负载平衡脚本,一起来看看吧!routeros双ADSL负载平衡脚本[plain] # may/25/2013 09:26:48 by RouterOS 5.20/ip firewall mangle add action=mark-connection c...

今天,教大家通过routeros设置双ADSL负载平衡脚本,一起来看看吧!

routeros双ADSL负载平衡脚本

[plain] # may/25/2013 09:26:48 by RouterOS 5.20

/ip firewall mangle add action=mark-connection chain=input disabled=no in-interface=pppoe-out1 new-connection-mark=wan1_conn passthrough=yes add action=mark-connection chain=input disabled=no in-interface=pppoe-out2 new-connection-mark=wan2_conn passthrough=yes add action=mark-routing chain=output connection-mark=wan1_conn disabled=no new-routing-mark=to_wan1 passthrough=yes add action=mark-routing chain=output connection-mark=wan2_conn disabled=no new-routing-mark=to_wan2 passthrough=yes add action=mark-connection chain=prerouting disabled=no dst-address-type=!local in-interface=wan1 new-connection-mark=wan1_conn passthrough=yes \ per-connection-classifier=both-addresses-and-ports:2/0 add action=mark-connection chain=prerouting disabled=no dst-address-type=!local in-interface=wan1 new-connection-mark=wan2_conn passthrough=yes \ per-connection-classifier=both-addresses-and-ports:2/1 add action=mark-connection chain=prerouting disabled=no dst-address-type=!local in-interface=wan2 new-connection-mark=wan1_conn passthrough=yes \ per-connection-classifier=both-addresses-and-ports:2/0 add action=mark-connection chain=prerouting disabled=no dst-address-type=!local in-interface=wan2 new-connection-mark=wan2_conn passthrough=yes \ per-connection-classifier=both-addresses-and-ports:2/1 add action=mark-routing chain=prerouting connection-mark=wan1_conn disabled=no in-interface=wan1 new-routing-mark=to_wan1 passthrough=yes add action=mark-routing chain=prerouting connection-mark=wan2_conn disabled=no in-interface=wan1 new-routing-mark=to_wan2 passthrough=yes add action=mark-routing chain=prerouting connection-mark=wan1_conn disabled=no in-interface=wan2 new-routing-mark=to_wan1 passthrough=yes add action=mark-routing chain=prerouting connection-mark=wan2_conn disabled=no in-interface=wan2 new-routing-mark=to_wan2 passthrough=yes

/ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=pppoe-out1 add action=masquerade chain=srcnat disabled=no out-interface=pppoe-out2

/ip route add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out1 routing-mark=to_wan1 scope=30 target-scope=10 add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out2 routing-mark=to_wan2 scope=30 target-scope=10 add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out1 scope=30 target-scope=10 add check-gateway=ping disabled=no distance=2 dst-address=0.0.0.0/0 gateway=pppoe-out2 scope=30 target-scope=10

这个脚本是从老外Alex复制来的,亲证好用,他原来是4线的。

可以往上加,修改2/0 2/1 为4/0 4/1 4/2 4/3网银也好用,并且下载带宽可以叠加。

interfaces里,拨号端是 wan1 wan2;接局域网是 lanPPPOE拨号是 pppoe-out1和pppoe-out2,使用这个默认名字比较好。

这几个符号改来改去,比较容易混淆。

网卡界面和拨号需要手动添加一下,主要是mangle和route两部分,复制后,在new terminal里面粘贴就可以了。

延伸阅读:
  • 本月热点
  • 随机推荐
路由人提示:如需转载本站无线连接及路由器设置等技术文章请您注明出处,谢谢!
Copyright © www.LuYouRen.com, All Rights Reserved.
  苏ICP备12075116号