您现在的位置 : 路由人 > 路由器设置 > 正文 IP地址冲突 路由人教你更换IP地址 / 如何防蹭网的终极解决办法 / 连接上192.168.1.1没有账号、密码输入框 /

单臂路由配置方法

静态路由与默认路由的配置:配置步骤:1、配置路由器接口的IP并开启接口2、配置静态路由3、查看路由表条目、路由器的配置4、配置PC机IP验证是否Ping通——静态路由配置命令Router(config)#ip route 目标网络地...

静态路由与默认路由的配置:配置步骤:1、配置路由器接口的IP并开启接口2、配置静态路由3、查看路由表条目、路由器的配置4、配置PC机IP验证是否Ping通——静态路由配置命令Router(config)#ip route 目标网络地址子网掩码 下一跳地址/本地接口——默认路由配置命令Router(config)#ip route 0.0.0.0 0.0.0.0 下一跳地址/本地接口。

静态路由配置步骤:[路由器R1的配置]

R1(config)#interface e0/0

R1(config-if)#ip add 10.0.0.1 255.0.0.0

R1(config-if)#no shutdown

R1(config-if)#interface e0/1

R1(config-if)#ip add 192.168.1.1 255.255.255.0

R1(config-if)#no shutdown

R1(config-if)#exit

R1(config)#ip route 192.168.2.0 255.255.255.0 e0/0 ——配置静态路由命令

R1(config)#exit R1#show ip route

[路由器R2的配置]

R2(config)#interface e0/0

R2(config-if)#ip add 10.0.0.2 255.0.0.0

R2(config-if)#no shutdown

R2(config-if)#interface e0/1

R2(config-if)#ip add 192.168.2.1 255.255.255.0

R2(config-if)#no shutdown

R2(config-if)#exit

R2(config)#ip route 192.168.1.0 255.255.255.0 10.0.0.1 ——配置静态路由命令

R2(config)#exit

R2#show ip route

接着上面的配置继续配置默认路由的步骤:

[路由器R1的配置]

R1(config)#no ip route 192.168.2.0 255.255.255.0 e0/0 ——删除静态路由表项

R1(config)#ip route 0.0.0.0 0.0.0.0 e0/0 ——配置默认路由表项[路由器R2的配置]

R2(config)#no ip route 192.168.1.0 255.255.255.0 10.0.0.1 ——删除静态路由表项

R2(config)#ip route 0.0.0.0 0.0.0.0 10.0.0.1 ——配置默认路由表项

单臂路由配置步骤:

1、在交换机上创建VLAN,接口开启trunk

2、在路由器开启主接口,配置其子接口IP

3、给PC即配置IP及网关

4、用ping检查链路

Router(config)#interface 接口类型 槽位/接口序号。子接口号

Router(config-subfit)#encapsulation dot1q vlan-id

Router(config-subfit)#ip address ip地址 子网掩码

具体配置步骤:

[交换机的配置]

s1(config)#interface f0/0

s1(config-if)#switchport mode trunk

s1(config-if)#no shutdown

s1(config-if)#exit

s1(config)#exit

s1#vlan database

s1(vlan)#vlan 2 name vlan2

s1(vlan)#vlan 3 name vlan3

s1(vlan)#exit

s1#config termical

s1(config)#int range f0/1 - 2 ——设置1和2口属于VLAN2

s1(config-if-range)#switch access vlan2

s1(config-if-range)#int range f0/10 - 11 ——设置10和11口属于VLAN3

s1(config-if-range)#switch access vlan 3

s1(config-if-range)#exit

[路由器的配置]

r1(config)#interface e0/0

r1(config-if)#no shutdown

r1(config-if)#interface e0/0.2

r1(config-subif)#encapsulation dot1q 2

r1(config-subif)#ip add 192.168.2.1 255.255.255.0

r1(config-subif)#int e0/0.3

r1(config-subif)#encapsulation dot1q 2

r1(config-subif)#ip add 192.168.3.1 255.255.255.0

路由器工作在网络层,根据“路由表”转发数据,路由选择,路由转发,而交换机工作在数据链路层,根据“MAC地址表”转发数据,硬件转发。

延伸阅读:
  • 本月热点
  • 随机推荐
路由人提示:如需转载本站无线连接及路由器设置等技术文章请您注明出处,谢谢!
Copyright © www.LuYouRen.com, All Rights Reserved.
  苏ICP备12075116号