您现在的位置 : 路由人 > 路由器设置 > 正文 IP地址冲突 路由人教你更换IP地址 / 如何防蹭网的终极解决办法 / 连接上192.168.1.1没有账号、密码输入框 /

H3C多网段网络互联设置

本篇主要介绍在不配置回指路由的情况下,实现多网段网络互联,这是为了以下两种情况:1、路由器为傻瓜型无法自己添加静态路由,以及仅能对本地直连网段做NAT。2、本来局域网是一个网段,后来因需要划分了多个网段...

本篇主要介绍在不配置回指路由的情况下,实现多网段网络互联,这是为了以下两种情况:

1、路由器为傻瓜型无法自己添加静态路由,以及仅能对本地直连网段做NAT。

2、本来局域网是一个网段,后来因需要划分了多个网段,又不想逐个修改IP地址和网关。

下面就仔细给大家讲解一下,这里我们假设电脑A在VLAN 10中,IP地址是192.168.10.0/24,电脑B在VLAN20中,IP地址是192.168.20.0/24,路由器在VLAN30中,IP地址是192.168.30.0/24。

一、配置过程

interface FastEthernet3/0

switchport access vlan 10

interface FastEthernet3/1

switchport access vlan 20

interface FastEthernet3/2

switchport access vlan 30

interface Vlan10

ip address 192.168.10.1 255.255.255.0

interface Vlan20

ip address 192.168.20.1 255.255.255.0

interface Vlan30

ip address 192.168.30.1 255.255.255.0

二、电脑网关可以设置为自身也可以设置为VLAN虚接口的网关,出口路由器的内网IP地址掩码要变小,此处为了方便选用了16bit,IP地址是192.168.30.2/16,无需添加任何静态路由,配置如下:

interface FastEthernet2/0

ip address 192.168.30.2 255.255.0.0

duplex auto

speed auto

R3# show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C? ? 192.168.0.0/16 is directly connected, FastEthernet2/0

R3#

H3C路由器设置多网段网络互联到此就已经完成,希望对大家有所帮助。

延伸阅读:
  • 本月热点
  • 随机推荐
路由人提示:如需转载本站无线连接及路由器设置等技术文章请您注明出处,谢谢!
Copyright © www.LuYouRen.com, All Rights Reserved.
  苏ICP备12075116号